CCS64 Forum

A forum to discuss issues about CCS64!
It is currently Sun Dec 17, 2017 10:06 am

All times are UTC + 2 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Tue Oct 07, 2003 5:05 pm 
Offline
Site Co-Admin

Joined: Wed Aug 20, 2003 2:46 pm
Posts: 786
Location: East Yorkshire, England
There are other problems also, with the different menu options interfering with each other - this used to happen before.

When you have a feature/function selected within the menu system, and you use the Function keys on the keyboard to perform some sub-function or to change the settings of a feature/function, it sometimes also triggers another feature/function/setting within the menu system. It is as if moving from one thing (feature/function) within the menu system to another is not clearing-out something from before.

e.g. When setting the speed with the function keys, this also caused CCS64 to save a bitmap screen-shot image, but not when CCS64 is started a-fresh.

I probably haven't explained it very well, but I think you know what I mean.

_________________
Kind regards,

Stuart Toomer.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 08, 2003 3:22 pm 
Offline

Joined: Mon Sep 22, 2003 4:44 pm
Posts: 11
I especially encountered this when switching to other applications. It is as if the ALT key stays pressed. Pressing ALT once seems to revert to normal behaviour. (until you switch to another program again)

Is a fix planned ? :)

PS: Stuart, did I mention it's great of you to help Per out ? That way he can use the little time he has to work on the emulator. We all appreciate it, thanks! :D

_________________
Kai Spitzley, heechee.net =)
lastninja.c64.org, girls.c64.org


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 08, 2003 5:42 pm 
Offline
Site Co-Admin

Joined: Wed Aug 20, 2003 2:46 pm
Posts: 786
Location: East Yorkshire, England
heechee wrote:
I especially encountered this when switching to other applications. It is as if the ALT key stays pressed. Pressing ALT once seems to revert to normal behaviour. (until you switch to another program again)

Is a fix planned ? :)

PS: Stuart, did I mention it's great of you to help Per out ? That way he can use the little time he has to work on the emulator. We all appreciate it, thanks! :D


That's no problem, I just want to organise the bug-reports and enhancement-requests for Hakan, so it is clear and also to give him as much information as possible. I might start to add a Priority to each bug-report?

The ALT+TAB issue is separate to this, in my eyes, but I'm not sure if they're connected - I am talking about interference within CCS64's own internal menu system, when you use the F1/F2/F3/F4 keys to do something.

The ALT+TAB thing is CCS64 responding to Windows itself, as a Windows process/task.

I didn't think the two issues were related. I thought the ALT+TAB issue was a 'Windows task' issue.

If I hear anything from Hakan, I'll keep the CCS64 Forum/CCS64 KB updated.

_________________
Kind regards,

Stuart Toomer.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 08, 2003 8:15 pm 
Offline

Joined: Mon Sep 22, 2003 4:44 pm
Posts: 11
My post was entirely unrelated to the Alt+TAB problem. ;) It was indeed about the ccs64 internal problem. And the problem seems to be a (virtually ;) ) stuck ALT key.

It happened that when I changed speed or swapped joystick ports something else would happen. (like a screenshot beng taken, as you mentioned)

I couldn't even press 1 in the emulator since it would always open the Tape Device 1 menu (ALT-1).
If I tap the ALT key once the keys work as usual.

I don't know what causes the ALT key to become stuck, it happened often after switching programs here. :)

_________________
Kai Spitzley, heechee.net =)
lastninja.c64.org, girls.c64.org


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 08, 2003 11:08 pm 
Offline
Site Co-Admin

Joined: Wed Aug 20, 2003 2:46 pm
Posts: 786
Location: East Yorkshire, England
OK, I'll keep people updated.

_________________
Kind regards,

Stuart Toomer.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC + 2 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group