CCS64 Forum

A forum to discuss issues about CCS64!
It is currently Mon Oct 20, 2014 1:18 pm

All times are UTC + 2 hours




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Clystron missing glitch
PostPosted: Thu Feb 07, 2008 11:52 pm 
Offline

Joined: Fri Jul 13, 2007 12:47 am
Posts: 9
Hi,

in the game Clystron, there's a visual bug, which CCS64 doesn't seem to emulate. It's a few stray pixels visible every couple of frames when you go to the right. I have verified that this glitch appears on a real C64. Below is the screenshot I took from Hoxs64, which shows the missing flaw.

Image

Hope this helps.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Feb 27, 2008 11:10 pm 
Offline
Site Co-Admin

Joined: Wed Aug 20, 2003 2:46 pm
Posts: 757
Location: East Yorkshire, England
Try this game again with Hoxs64 1.0.5.17, which has been released, and contains various bug-fixes.

_________________
Kind regards,

Stuart Toomer.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Feb 29, 2008 12:22 am 
Offline

Joined: Fri Jul 13, 2007 12:47 am
Posts: 9
As I said, the presence of the glitch on a real C64 was verified, which suggests an inaccuracy exists in CCS64.

Hoxs64 v1.0.5.17 still displays the same as a real C64.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Feb 29, 2008 9:42 am 
Offline
Site Co-Admin

Joined: Wed Aug 20, 2003 2:46 pm
Posts: 757
Location: East Yorkshire, England
I am having difficulty seeing a glitch with this screen-shot - what is the graphical glitch? I use C64 Kernel Revision 3 with CCS64 (CCS64 gets released with C64 Kernel Revision 2) and it looks the same as Hoxs64 does to me (thereagain I've only looked quickly). So, perhaps try that. Which crack are you using? I downloaded mine from:
http://c64.hardwired.hu/

_________________
Kind regards,

Stuart Toomer.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Mar 01, 2008 1:57 am 
Offline

Joined: Fri Jul 13, 2007 12:47 am
Posts: 9
Use the version from GB64: http://gamebase64.hardabasht.com/games/c1/CLYSTRON_01536_01.zip

The glitch:

Image

I use CCS64 v3.5 + Kernal v3, and the pixels are still missing.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Mar 01, 2008 9:29 pm 
Offline
Site Co-Admin

Joined: Wed Aug 20, 2003 2:46 pm
Posts: 757
Location: East Yorkshire, England
I get a glitch the same when walking right with that crack of Clystron in CCS64 V3.5. I am not firing here, just walking (you can see the same glitch clearly):
http://homepage.ntlworld.com/stuart.toomer/ccs64/Clystron_Glitch_CCS64V35.bmp

I used the Load (Normal) option for loading the game, not the default fast-loader. So, I cannot see an emulation problem here.

_________________
Kind regards,

Stuart Toomer.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC + 2 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group