CCS64 Forum

A forum to discuss issues about CCS64!
It is currently Sat Dec 16, 2017 1:10 pm

All times are UTC + 2 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Sun Sep 07, 2008 12:56 am 
Offline

Joined: Sun Sep 07, 2008 12:26 am
Posts: 3
A friend and I both got CCS and a bunch of C64 games in d64 format. We've tried playing International Karate (and a few other things) over the internet, using the instructions in CCS64.html that came with the emulator.

It worked the first time, except my friend was controlling both our characters because we didn't set up the joystick keysets correctly. So we terminated that session, went into options and both turned off the port we wouldn't be using.

After that we couldn't join each other's games on Kalliera because of the "This ROM is not available on your computer!" error. This confused us a while because my friend is using exactly the same file as I am; after all I sent all those games to her. We finally figured we should try re-enabling those ports because maybe the game is detecting different settings or something.

This worked... partially. We now can join each other's games on the Kalliera thing again, but when we start a game, it starts correctly only for me. The friend gets a "?File not found" problem in the emulator. We haven't been able to get around it since.

This is not because of any corruption to files, I'm sure - we're using the same files, again, and I re-sent the same thing a second time to be sure... and we can each play solo games. Also as far as I know neither of us messed with anything other than the Input options. Also this is a problem with all games we've tried, not a specific one. Lastly, the error happens whichever of us is hosting the game - it turns for me (usually) but not for her.

It's very frustrating. Please help!


Top
 Profile  
 
PostPosted: Sun Sep 07, 2008 6:03 pm 
Offline
Site Co-Admin

Joined: Wed Aug 20, 2003 2:46 pm
Posts: 786
Location: East Yorkshire, England
Hmmm... This is a strange problem. Never had this reported before. Possible suggestions are:

1. Check the stability of the Internet connection/server being used (data corruption);
2. Check the version of the 1541 ROMs and Kernel ROMs (Kernel ROM should be Revision 3);
3. Check that the game image file/s isn't/aren't corrupted;
4. Set the maximum 1541 Speed option to OFF;

Settings should be the same within both parties' instances of CCS64.

I don't know what else to suggest really. As I say, I've never had any suh problem reported before this post.

_________________
Kind regards,

Stuart Toomer.


Top
 Profile  
 
PostPosted: Tue Sep 09, 2008 1:54 am 
Offline

Joined: Sun Sep 07, 2008 12:26 am
Posts: 3
Thanks for the response, but I'm still stuck.

1. We tried another server, it didn't help.

2. Can you please explain how to do that?

3. I would have imagined that the fact that we can both play the images solo means they're not corrupted... if not, how else do I check?

4. Tried that, it didn't change anything.


Top
 Profile  
 
PostPosted: Tue Sep 09, 2008 10:41 am 
Offline
Site Co-Admin

Joined: Wed Aug 20, 2003 2:46 pm
Posts: 786
Location: East Yorkshire, England
Download the following ZIP file, to somewhere separate to your CCS64 installation folder:
http://homepage.ntlworld.com/stuart.too ... v35_32.zip

It contains my installation of CCS64 V3.5, with the C64 Kernel Revision 3 (KERNAL.ROM) and the C64 1541 ROM (C1541.ROM). You could over-write the KERNAL.ROM / C1541.ROM files in your CCS64 installation folder with those files in the ZIP file above - the same goes for your friend.

Then, if even this doesn't resolve this weird problem, I don't know what else to suggest.

_________________
Kind regards,

Stuart Toomer.


Top
 Profile  
 
PostPosted: Fri Sep 12, 2008 2:27 am 
Offline

Joined: Sun Sep 07, 2008 12:26 am
Posts: 3
Thanks.

Well, they're exactly the same files as what we have, and it didn't help...

What server can I catch some C64 players on? So I can try it out with someone else.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC + 2 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group