CCS64 Forum
http://www.ccs64.com/forum/

Problem after hitting F10 key
http://www.ccs64.com/forum/viewtopic.php?f=1&t=25
Page 1 of 1

Author:  carrrramba [ Wed Sep 17, 2003 11:38 pm ]
Post subject:  Problem after hitting F10 key

Hi Hakan & friends, <-- don't get that 'thing' over the a ... i'm sorry ;-P

first off, thank you for the new version - i'm very happy that you still find the time to develop this great software of yours - gives me the feeling that my decision to register was right, 2 years ago *g*

...but i encounter the following: if i press the F10 key to enter the menu
the window option 'file' (in top of the window, where it says: 'file' 'view' 'help') always gets hilighted - i have to click into the window to keep going with the intern menu. It does this even in fullscreen mode - where you cannot really see the window options :-)

is this just me - am i doing something wrong?

cheers
stefan

Author:  StevenRoy [ Thu Sep 18, 2003 1:23 pm ]
Post subject:  Try F9

I would think that the "internal" menu would be accessed the same way as in CCS64 v2.0... The F9 key (not F10).

I really should try that 3.0 version some day.

Author:  Tross [ Fri Nov 21, 2003 9:59 pm ]
Post subject: 

After a few slowdowns I have finally been able to get the CCS64 window to come up, albeit not full screen yet. I have tried accessing the menu with both F9 and F10 but only seem to be able to get the blue screen to pop up, nothing else except escape will access out of it. I have tried different key comands and searched the forums but haven't been able to locate any post specifically addressing this. If someone could guide my efforts I would be most thankful.

Author:  Stuart Toomer [ Sat Nov 22, 2003 3:04 pm ]
Post subject: 

Well, for me, both F9 or F10 make the internal menu appear!

Author:  zaphod [ Sun Nov 23, 2003 12:48 pm ]
Post subject: 

I've seen this bug too! it happens under 98. it thinks you pressed alt, and activates the windows menu!

Author:  Stuart Toomer [ Sun Nov 23, 2003 1:25 pm ]
Post subject: 

All menus in Windows applications appear when you press ALT, because the short-cuts are [ALT] + [Letter] / [Function Key]. So, this is not a bug, but is the way that Windows application menus work!

Author:  zaphod [ Mon Nov 24, 2003 4:26 am ]
Post subject: 

BUT, it doesnt' happen on my xp box. ccs sucesfuly intercepts the alt key on that OS.

Author:  StevenRoy [ Sat Dec 06, 2003 6:35 am ]
Post subject: 

In my Windows XP system, the computer beeps every time I use an Alt+key combination to access, for example, the sound settings or the drive 8 menu. That doesn't happen if I press F9 to navigate the menus, but I've become used to the Alt+key combinations and don't want to have to abandon them just because the beeping (caused by the menu bar, no doubt) annoys me.

I can think of a possible compromise, though... Hide the menu bar until it's activated with F10 (the standard Windows "menu" key). Perhaps the emulation could also be paused while the menu bar is active. Then, when the user hits Escape or F10 again to get out of the menu bar, the menu bar hides and emulation resumes. In a way, the menu bar would end up working just like the F9 menu. That might be good; it might not.

Of course, if the menu bar ceases to exist while CCS64 3.0 is running in a full-screen mode (I haven't tried it yet; shame on me!) then the whole problem probably solves itself at those times.

EDIT: Tried a full-screen mode. The menu bar was invisible as predicted but it still tried to come up when I hit Alt. I had to hit Esc to get back to the emulation. That definitely goes on the to-fix list, I think.

Page 1 of 1 All times are UTC + 2 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/