CCS64 Forum
http://www.ccs64.com/forum/

Sound emulation failure - help!
http://www.ccs64.com/forum/viewtopic.php?f=1&t=158
Page 1 of 1

Author:  cdearborn [ Thu Mar 11, 2004 4:51 am ]
Post subject:  Sound emulation failure - help!

When I start CCS64 V3.0 Beta 1.3, a dialog pops up that says "DirectSoundCreate(): DSERR_ALLOCATED". Once I click OK, the emulator runs fine, but when I load a game I get no sound.

My system is W2K Pro (SP 4 w/latest patches), 800Mhz P3, Geforce 2 GTS, SoundBlaster Live Value, DirectX 9.0b.

Tried "Test Direct Sound" from dxdiag & all tests ran fine.

I haven't played a game of M.U.L.E. in over 10 years, and I can't wait! :D

Author:  Stuart Toomer [ Thu Mar 11, 2004 11:24 am ]
Post subject: 

Is there a memory problem with your computer?

Author:  cdearborn [ Thu Mar 11, 2004 1:58 pm ]
Post subject: 

Not that I'm aware of. Have been running many other applications with no problem: quake 3, warcraft 3, ms office, AOL, Mame, etc, etc.

I have 512 megs of RAM.

Author:  StevenRoy [ Fri Mar 12, 2004 12:38 am ]
Post subject: 

"DSERR_ALLOCATED" sounds like the sort of error you might get if some other program is using the sound card while CCS64 is trying to "allocate" the card. If you have a "Program Start" sound set up on your computer, or you have something else running that uses sound, that may be the cause of it. I have also heard of cases where programs such as WinAmp fail to release the sound card properly when they're not playing sound.

One thing you should try is to go into the CCS64 menu, go into the sound options, and try selecting another sound device.

Author:  cdearborn [ Fri Mar 12, 2004 4:50 am ]
Post subject: 

Well, exited all apps, exited everything in the system tray & then started shutting off services one at a time. Got down to very few processes running & still get the same error.

Tried shutting off sound scheme & that didn't work either.

Rebooted & tried CCS64 V2 & that works ok. Would much rather have a windowed version, but it looks like I'm in business for some serious MULE (gotta love the sound!).

Thanks for the help!

Chris

Author:  iAN CooG/HF [ Sun Mar 14, 2004 2:41 am ]
Post subject: 

cdearborn wrote:
Would much rather have a windowed version

ccs -window
in ccs 2.0b (feb 2002, win9x)

Page 1 of 1 All times are UTC + 2 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/