CCS64 Forum
http://www.ccs64.com/forum/

Joystick Problems
http://www.ccs64.com/forum/viewtopic.php?f=1&t=154
Page 1 of 1

Author:  Darcman [ Fri Mar 05, 2004 12:55 am ]
Post subject:  Joystick Problems

I came across your emulator and a website that offers various games from the C64. First of all, thanks for all the memories that came rushing back to me! I almost had to go find my old Twisted Sister shirt!

Anyway, is there any way at all to get a Microsoft Sidewinder Freestyle Pro to work with the emulator?

I'm not sure if I can get around the problem of needing a DOS joystick. If there is a way, I'd sure appreciate you telling me how! I'm just dying to hear that scream from Impossible Mission again!

Author:  nicknicknickandnick [ Sun Mar 14, 2004 2:45 am ]
Post subject: 

Any PC joystick or gamepad should work.

Look at your settings for input. You need to have your PC game controller set as if it was in one of the Commodore 64's two game controller ports. Whatever emulator you use, it's not a good idea to set the same PC game controller to both ports at the same time, because many games will not work properly. Some games use just the Commodore 64's port number 1, some use just port number 2, and some use both ports.

Press the F10 key, use the arrow keys to choose Options... (highlight then right arrow or Enter key), Input..., then Control Port 1. Use the right arrow key or F1 key to see each next choice for Control Port 1, and leave it with Joystick. Use the down arrow key to highlight Mode under Control Port 1, and use the right arrow key or F1 key to see the choices, and leave it with PC Gameport 1 (assuming you want to use the game controller you have listed in Windows Control Panel as controller #1).

Before the emulator will let any game controllers work, you need to do the Calibrate Joysticks procedure (highlight those words and use the right arrow key or F1 key to get to the Joystick Callibration screen). Use your game controller so that the direction words and button words change colour, and the emulator will then allow the controller to work. Press the Esc key four times to get out of the menu screens. If you find that you can't do anything in a game, it may be that the game requires Joystick in Control Port 2. You can press the Alt key with the F10 key to move the PC Gameport 1 setting to Control Port 2 (and you can repeat those key pressings to switch the setting back).

Author:  Darcman [ Wed Mar 17, 2004 6:59 am ]
Post subject: 

I got it working. Thanks to all who tried to help me out, however, it was my own stupidity that kept things from working smoothly.

I had recently re-formatted my hard drive and I simply forgot to tell my computer to search for a joystick that was installed!!!

Do I feel like an idiot?

The answer is simply...yes!

Thanks again to everyone!

Author:  nicknicknickandnick [ Sat Mar 20, 2004 9:44 am ]
Post subject: 

You're welcome. :)

Page 1 of 1 All times are UTC + 2 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/